Provisioning: Fix virtualenv in macOS 10.11
authorSimo Fält <simo.falt@qt.io>
Mon, 17 Jul 2017 08:10:53 +0000 (11:10 +0300)
committerSimo Fält <simo.falt@qt.io>
Wed, 19 Jul 2017 05:54:01 +0000 (05:54 +0000)
There are multiple Python installations in our macOS 10.11 Tier1
template. Most of them are pretty old and not even working properly.
One of the affected Python tool is virtualenv, which atm is creating
Python 2.6 env by default even if Python 2.7 is the default Python.

Change-Id: I8bc0900976a9dc79637539802345175c85b7b433
Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
coin/provisioning/qtci-osx-10.11-x86_64/004-fix-virtualenv.sh [new file with mode: 0755]

diff --git a/coin/provisioning/qtci-osx-10.11-x86_64/004-fix-virtualenv.sh b/coin/provisioning/qtci-osx-10.11-x86_64/004-fix-virtualenv.sh
new file mode 100755 (executable)
index 0000000..f364657
--- /dev/null
@@ -0,0 +1,17 @@
+#!/usr/bin/env bash
+
+# macOS 10.11 template doesn't have working virtualenv installation.
+# To fix that, we first have to install pip to install virtualenv
+# Install pip
+curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py
+sudo python get-pip.py
+rm get-pip.py
+
+# remove link pointing to broken virtualenv
+sudo rm /opt/local/bin/virtualenv
+sudo pip install virtualenv
+
+# fix the link. This is optional, while the new installation is
+# already in PATH, but there will be virtualenv-2.6 in /opt/local/bin
+# which might be confusing
+sudo ln -s /usr/local/bin/virtualenv /opt/local/bin/virtualenv