Remove platform-specific logic for qtactiveqt module.
authorRohan McGovern <rohan.mcgovern@nokia.com>
Fri, 13 May 2011 00:13:24 +0000 (10:13 +1000)
committerRohan McGovern <rohan.mcgovern@nokia.com>
Fri, 13 May 2011 02:05:56 +0000 (12:05 +1000)
For the sake of a uniform test procedure, it is cleaner to have
`make module-qtactiveqt' always working, but simply not building
anything on platforms where ActiveQt is not supported.

Without this, any test procedure for building Qt5 needs to be able
to know or determine that ActiveQt should only be built on Windows.

Reviewed-by: Jason McDonald
Change-Id: I3869bbacdc6598a764561a4b9f6042c49e6ffae8

qt.pro
qtactiveqt

diff --git a/qt.pro b/qt.pro
index f174aed..78cff58 100644 (file)
--- a/qt.pro
+++ b/qt.pro
@@ -85,10 +85,10 @@ SUBDIRS       = \
                 module_qlalr \
                 module_qtqa \
                 module_qtlocation \
+                module_qtactiveqt \
 
 exists(qtwebkit/Tools/Scripts/build-webkit) {
     SUBDIRS +=  module_qtwebkit \
                 module_qtwebkit_examples_and_demos
     module_qttools.depends += module_qtwebkit
 }
-win32:SUBDIRS += module_qtactiveqt
index e2deded..6729e60 160000 (submodule)
@@ -1 +1 @@
-Subproject commit e2deded490725473f1bb0b042e5022fffe534f2c
+Subproject commit 6729e60cfac84e8f6eb28cf473ce0c75f88d35cd